Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on hello@boards.ie for help. Thanks :)
Hello all! Please ensure that you are posting a new thread or question in the appropriate forum. The Feedback forum is overwhelmed with questions that are having to be moved elsewhere. If you need help to verify your account contact hello@boards.ie

Cisco 800

Options
  • 02-07-2001 1:55pm
    #1
    Closed Accounts Posts: 649 ✭✭✭


    <font face="Verdana, Arial" size="2">Originally posted by Canaboid:
    Can't help ya with the problem Eric, sorry.
    However you may be able to help me smile.gif
    I have an 800 on my desk here which i want to use at home. Any ideas on a config to connect to eircom's free dial up ?
    </font>

    SAMPLE router configuration for Multi User Isdn.

    Cisco-EIRCOM NET, Multi-user ISDN

    no service finger
    service password-encryption
    no service udp-small-servers
    no service tcp-small-servers

    hostname

    enable password router password This is the router password NOT the Eircom net password

    *isdn switch-type basic-net3 (1)

    ip subnet-zero
    no ip source-route

    interface Ethernet0
    description Local LAN interface
    *ip address 195.7.xxx.xxx 255.255.255.240 (2) router address on your LAN
    * no ip directed-broadcast (3)

    interface BRI0
    description ISDN link to TINET
    *ip unnumbered Ethernet0 (4)
    *encapsulation ppp (5)
    dialer idle-timeout 180 hang up after 3 inactive minutes
    *dialer string 1891150150 (6)
    dialer hold-queue 10 queue packets before dialling
    *dialer load-threshold 255 (7) Maximum load threshold
    dialer-group 1 see dialer-list below
    *ppp authentication chap callin (8)

    * ppp chap hostname (9)Username for connecting to eircom net
    *ppp chap password (10) your Eircom net password

    * ip name-server 159.134.237.6 (11)
    * ip name-server 159.134.237.59 (11)
    * ip classless (12)
    no ip route-cache (13)
    * ip route 0.0.0.0 0.0.0.0 BRI0 (14) send all traffic over isdn
    dialer-list 1 protocol ip list 101 (15) allows access list 101 to dial
    access-list 101 permit ip195.7.xxx.xxx 0.0.0.15 any (16) only IP traffic permitted

    no snmp-server

    line con 0
    exec-timeout 5 0
    line aux 0
    transport input none
    line vty 0 4
    access-class 1 in
    exec-timeout 5 0
    password routerconsolepassword

    (1) ISDN switch-type basic-net 3

    This is the switch type that needs to configured to allow the router to establish
    a connection .

    (2) ip address 213.190.xxx.xxx 255.255.255.240

    This is the IP address and the subnet mask that should be assigned to the ethernet
    interface. The first available IP address from your range should be added here.

    (3) no ip direct-broadcast

    This command stops the client from responding to a possible DOS (Denial of Service)
    attack and also stops client broadcasts from bringing up the line.

    (4) ip unnumbered Ethernet0

    This command is added to the brio interface as an ip address is not needed for this
    interface, this commands tells the interface to use the ip address from the
    Ethernet interface .

    (5) Encapsulation ppp

    Encapsulation takes packets or frames from one network system and places them
    inside frames from another network system. This command has to be applied to the brio interface.
    The Encapsulation type used to connect over an ISDN line is PPP

    (6)dialer string 1891150150

    The number that your router must dial for internet access.

    (7)dialer load threshold 255

    This is the command that keeps the second ISDN channel from coming up straight away.
    If you have dual channel access you need to set the threshold to 1-130 instead of 255.
    Setting the load to 1-130 sets the maximum load before the dialer places another call
    through the second b channel. The command ppp multilink will also have to be added to
    the router configuration if a second channel is to be used.

    (8)ppp authentication chap callin

    The protocol that has to be used to allow the router to connect. If PAP is configured the
    router will not connect. CHAP is the authentication type used by Eircom Net.

    9)ppp chap hostname

    This is the Username for the eircom net dial up account.

    10)ppp chap password

    This is the password for the eircom net dial up account.

    (11)ip name servers

    These are the eircom net dns servers.

    (12)ip classless

    This command forwards packets to a network that has no network default route
    It allows the router to establish a connection with ip addresses from the eircom
    range. If this command is not added you will be unable to connect to any
    eircom sites and will also be unable to collect smtp mail if they are using this service.

    (13)no ip route-cache

    ip route-cache this command enables fast switching on the cisco router. It is advisable
    to include this command in the configuration for load balancing, but only if it is a Dual
    Channel account (128 kps), if you have a single channel account (64Kps) then you would
    use no ip route-cache.

    (14)ip route 0.0.0.0 0.0.0.0 bri0

    This ip route command creates a default route to the Eircom network via the remote
    router's BRI interface. This also allows the clients to send traffic through the brio interface.

    (15)dialer-list 1 protocol ip list 101

    The dialer-group 1 command enables the dialer-list 1 on the BRI interface, which
    determines which packets activate the ISDN connection.

    (16) access-list 101 permit ip195.7.xx.xxx 0.0.0.15 any

    Access lists can permit certain ip addresses to connect while denying other ip
    addresses from connecting to the internet. If you are having problems connecting
    you should temporarily remove the access lists to eliminate them as the cause of
    the problem.


Comments

  • Closed Accounts Posts: 296 ✭✭moist


    <font face="Verdana, Arial" size="2">Originally posted by Canaboid:

    I have an 800 on my desk here which i want to use at home. Any ideas on a config to connect to eircom's free dial up ?
    </font>

    Generally somthing along the lines of...

    configure terminal
    interface Ethernet0
    ip address 192.168.0.1 255.255.255.0
    no ip directed-broadcast
    ip nat inside (assuming you want nat)
    exit

    interface BRI0
    no ip address
    no ip directed-broadcast
    ip nat outside (assuming you want to nat)
    encapsulation ppp
    dialer rotary-group 0
    isdn switch-type basic-net3
    no fair-queue
    no cdp enable
    exit


    interface Dialer0
    ip address negotiated
    no ip directed-broadcast
    ip nat outside
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 300
    dialer string <Phone no. 1891 150150 ?> class 64K
    dialer hold-queue 10
    dialer load-threshold 200 either
    dialer-group 1
    no fair-queue
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username <username> password <password>
    ppp multilink
    exit


    ip nat translation timeout 1800
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0

    <edit> *cough* or what TCSM said... </edit>


    [This message has been edited by moist (edited 02-07-2001).]


  • Registered Users Posts: 2,207 ✭✭✭MindPhuck


    Thats really cool info guys. Big thanks.

    But alas, even after setting the Dialer idle-timeout to 300, it keeps going back to 180! It tells me that SYS-5-CONFIG_I: Configured from console by console, so I think I have saved these details. But im still getting that problem, maybe im doing something completely arseways (asif!! smile.gif)

    If you can help further, It'd be great. Thanks.


  • Registered Users Posts: 1,641 ✭✭✭Canaboid


    "Copy run start" to save your changes ? Just a guess.

    Thx for the detailed help lads. I'll be back for more smile.gif


  • Closed Accounts Posts: 296 ✭✭moist


    <font face="Verdana, Arial" size="2">Originally posted by MindPhuck:
    SYS-5-CONFIG_I: Configured from console by console
    </font>

    Just a status message telling you you just configured it from the console, mad, but hey!
    <font face="Verdana, Arial" size="2">
    If you can help further, It'd be great. Thanks.
    </font>

    I suppose you could always post your config up here and we can have a looksee if there is anything amiss.



  • Registered Users Posts: 2,207 ✭✭✭MindPhuck


    Yeah I would. But tbh, I don't know how to get it to display the full config..

    <-- is not a cisco head as one can gather.


  • Advertisement
  • Closed Accounts Posts: 649 ✭✭✭The Cigarette Smoking Man


    <font face="Verdana, Arial" size="2">Originally posted by MindPhuck:
    Yeah I would. But tbh, I don't know how to get it to display the full config..

    <-- is not a cisco head as one can gather.
    </font>

    Connect into the router using Hyperterminal and at the enable prompt type: show run


  • Registered Users Posts: 2,207 ✭✭✭MindPhuck


    Thanks TCSM.

    Im already hypered in, just was'nt sure of the commands to do it.

    I'll give it a whirl in work 2morrow.


  • Registered Users Posts: 2,207 ✭✭✭MindPhuck


    Right,

    This will test you cisco heads. Ive a cisco 800 router (used for net access). It is set to drop the connection after 180 seconds - regardless if there is activity on it. It supposed to timeout if there is no traffic, but it drops the connect every time at 180 secs.

    I get into it, and try and change the dialer-timeout command, but it comes back saying it was an incorrect command or something.

    btw, the Cisco IOS ver is 12.0(5)T if thats any help. I would REALLY appreciate any help on this one guys.

    Any ideas please ?


  • Closed Accounts Posts: 296 ✭✭moist



    Try...

    config terminal
    interface Dialer0
    dialer idle-timeout 300



  • Registered Users Posts: 1,641 ✭✭✭Canaboid


    Can't help ya with the problem Eric, sorry.
    However you may be able to help me smile.gif
    I have an 800 on my desk here which i want to use at home. Any ideas on a config to connect to eircom's free dial up ?


  • Advertisement
  • Registered Users Posts: 2,207 ✭✭✭MindPhuck


    Ok lads,

    As requested, heres my config, which I hope you might be able to spot something -


    Current configuration:
    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname jarltisdn
    !
    no logging buffered
    enable secret 5 (PW REMOVED)
    !
    !
    !
    !
    !
    ip subnet-zero
    no ip source-route
    !
    ip name-server 192.111.39.1
    no ip finger
    isdn switch-type basic-net3
    isdn tei-negotiation first-call
    !
    !
    process-max-time 200
    !
    interface Ethernet0
    ip address 192.0.0.120 255.255.255.0
    no ip directed-broadcast
    ip nat inside
    no ip route-cache
    !
    interface BRI0
    description Internet Connection
    ip address negotiated
    no ip directed-broadcast
    ip nat outside
    encapsulation ppp
    dialer idle-timeout 180
    dialer string 1891133133
    dialer hold-queue 10
    dialer load-threshold 255 outbound
    dialer-group 1
    isdn switch-type basic-net3
    ppp authentication chap callin
    ppp chap hostname (HOST NAME REMOVED)
    ppp chap password 7 (PW REMOVED)
    !
    interface Dialer0
    ip address negotiated
    no ip directed-broadcast
    ip nat outside
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 300
    dialer hold-queue 10
    dialer load-threshold 200 either
    dialer-group 1
    no fair-queue
    !
    ip nat pool mail_server 192.0.0.100 192.0.0.100 netmask 255.255.255.0 type rotar
    y
    ip nat inside source list 10 interface BRI0 overload
    ip nat inside destination list 111 pool mail_server
    no ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 BRI0
    !
    access-list 10 permit 192.0.0.0 0.0.0.255
    access-list 111 permit tcp any host 193.95.164.179 eq smtp
    access-list 121 deny ip any 0.0.0.255 255.255.255.0
    access-list 121 deny ip any host 192.0.0.255
    access-list 121 permit ip 192.0.0.0 0.0.0.255 any
    dialer-list 1 protocol ip list 121
    !
    line con 0
    exec-timeout 5 0
    password 7 (PW REMOVED)
    login
    transport input none
    escape-character 27
    stopbits 1
    line vty 0 4
    access-class 10 in
    exec-timeout 5 0
    password 7 (PW REMOVED)
    login
    escape-character 27
    !
    end


  • Closed Accounts Posts: 649 ✭✭✭The Cigarette Smoking Man


    How about getting rid of the dialer-idle timeout?

    config t
    int bri0
    no dialer idle-timeout 180
    exit
    int dialer0
    no dialer idle-timeout 300
    end

    If that works, try putting them back in one at a time.


  • Registered Users Posts: 2,207 ✭✭✭MindPhuck


    Thanks guys.

    I was able to at least extend my timeout from this. I simply pushed the bri0 idle-timeout to 1000 which gives me approx 15 mins on-line time.

    Unfortunetly, it still brings the line down at exactly 1000 seconds, regardless if I am doing anything or not. Rather strange.

    Again, thanks for the help.


  • Closed Accounts Posts: 3 jameskeane


    Still having problems with interesting traffic ???

    If this is still a problem let me know.

    Does anyone know if you can conifgure a CISCO804 to work
    with UTV Internet ??

    I have it working with Eircom ..
    works very well

    With the UTV it makes the call and then drops it straight away.

    I am using my username and password (works fine with a modem)


    Thanks

    James


Advertisement